(云反馈)已经设置了rtx通讯集成,现在的问题是:
已经设置了rtx通讯集成,现在的问题是:在OA登录页面,系统无法记住用户的选择。我选择验证方式为:“RTX集成”。关掉浏览器再打开oa,默认的验证方式又变为:“系统密码”。我想默认选择为“RTX集成”,不知道怎么实现?谢谢!!  

解决办法:oa\\webapp\\themes\\mskin\\login\\new\\login.jsp 文件中,在最后 位置,加上 :

% if (true.equals(Constants.RTX)) { %
script type=text/javascript
var selectObj=document.getElementsByName(selectLoginType)[1];
for (i=0; i selectObj.options.length; i++){
    var curOptObj=selectObj.options(i);
    var curText=curOptObj.text;
    if(curText==RTX登录){
        curOptObj.selected=selected;
    }
    changeMode(selectObj);
}
/script
% } %

oa\\webapp\\themes\\mskin\\login\\new\\login.jsp 文件中,在最后 位置,加上 :
按照说明添加了,但是还是那样啊!没有什么变化!

劳烦尽快回复,为盼!!!

微信扫一扫
分享
举报
您需要登录后才可以回帖 登录 | 注册

  • wubeiwa 管理员 板凳
    2015-03-25 显示全部楼层
    你需要登录才可以查看 登录 | 注册
  • cocotao 出类拔萃 沙发
    2015-01-30 显示全部楼层
    oa\webapp\themes\mskin\login\new\login.jsp 文件中,在最后 位置,加上 :
    <% if ("true".equals(Constants.RTX)) { %>
    <script type="text/javascript">
    var selectObj=document.getElementsByName('selectLoginType')[0];
    for (i=0; i< selectObj.options.length; i++){
        var curOptObj=selectObj.options(i);
        var curText=curOptObj.text;
                if(curText=='RTX集成'){
            curOptObj.selected='selected';
        }
        changeMode(selectObj);
    }
    </script>
    <% } %>
  • 你需要登录才可以查看 登录 | 注册
  • 你需要登录才可以查看 登录 | 注册
  • 你需要登录才可以查看 登录 | 注册
  • 你需要登录才可以查看 登录 | 注册
  • 你需要登录才可以查看 登录 | 注册
  • 你需要登录才可以查看 登录 | 注册
  • 你需要登录才可以查看 登录 | 注册